
DataLink Release Notes 
 

Build 2.5d: 10/05/2005 JG 
1) Added CG plot to G2X_Demo.rpk. 
2) Added can parameter files to support new round gauge product types. 

 
Build 2.5f: 1/12/2006 JG 
1) Added CAN_GAUGE.canparm file for backward compatablility. 
2) Modified J1939_MOD.canparm file in the following way: 

a) Changed max ECU number from 4 to 255 
3) Modified G2X_STB_10bit. canparm and G2X_STB_16bit.canparm in the following ways: 

a) Changed max smoothing from 500 to 100 points 
b) Changed Delay after Reboot from 1000ms to 1500ms to fix problem with changes 

sometimes not taking. 
4) Modified SC_ANALOG.canparm file in the following way: 

a) Added sensor type for IR temp sensor 810-SN-IR-TEMP 
5) Fix unsupported TMDATA error when attempting to upload data from V500 with individual 

timing enabled 
6) Fixes displaying warnings for every packet when uploading data from a CF or SD card 

using multi block data storage method. (i.e. G2X) 
 
Build 2.8a: 12/18/2006 JG 

1) Added DataLink support for metric track mapping. 
2) Added G2X_Config_Metric.rcg for G2X metric runlog support 
3) Added G2XPro canparm support files. 

 
Build 2.8b 12/27/2006 JG 

1) Fixed bug in metric distance scaling in DataLink 
2) Fixed bug in product type in file G2XP_Analog.canparm 
3) Added file G2X_Event.canparm 

 
Build 3.0a: 1/16/2008 JG 

1) Added ability to scan for Racepak hardware on serial ports 1-10 and set the proper COM 
port if a valid device is found. 

2) User will now be prompted whether to scan COM ports if Reading or Writing Config fails. 
3) Real-time telemetry COM ports is now set under Setting->Preferences COM Port option 

instead of the inside the configuration file. 
4) Added dialog boxes for IQ3. 
5) Added canparm files to support the following devices 

a) IQ3 display only dash 
b) IQ3 logger dash 
c) USM 
d) Racepak 4 channel air/fuel module 
e) Racepak single channel air/fuel module 

6) Added the following CAN ID’s 
a) Air Control 1-5 under new category “Air Control” 
b) Nitrous Stage 4. Move nitrous ID’s from “Fuel” category to new category “Nitrous”. 

7) Changed all reference in CanID.canset from PSI to Press 
 
 

Build 3.0b: 2/16/2008 
1) Added support for more than 4 characters on IQ3 display tags. 
2) Added IQ3 configs for boats and pullers. 



Build 3.0c: 2/25/2008 
1) Fixed incorrect channel linking to GPS gap correction on IQ3 config files. 
2) Added IQ3_config support for version 3 firmware which added gear logging. 
3) Added the following canparm files: 

a) Haltech_ECU.canparm 
b) GenCan_Mod.canparm 

 
Build 3.1.0 3/24/2008 

1) The version numbering method has been changed from #.#X to #.#.# 
2) Changed help system to be compatible with Windows Vista. 
3) Modified some of the IQ3 dialog boxes. 
4) Added option in Setting->Preferences to disable the X that appears on the time cursor. 
5) Changed the terminology used in some of the menu and dialog boxes. 
6) DataLink setup program now installs the Racepak USB to Serial port adaptor driver 

automatically for Windows Vista and XP. 
7) Fixed problem that would not allow some users to open Boat Demo file. 
8) Updated IQ3 pdf user manual to version 2. 

 
 
Build 3.1.1 3/27/2008 

 
1) Fixed problem that could cause program to crash when downloading data in v3.1.0. 
2) Removed New File Naming Scheme option from the Settings->Preferences menu. 

 
 
Build 3.1.2 4/17/2008 

 
1) Fixed issue that was causing the radio button for the OR/AND option to not function 

properly in the IQ3 warning dialog box. 
2) Added a calibration table in the Universal Sensor Module for 100 PSI resistive pressure 

sensors. Selecting this sensor type will automatically setup the User Cal Table 
Values. The table is optimized for Racepak part number 810-PT-0100SD. However, the 
table should work with most other 100 PSI resistive type pressure sensors with little or no 
modification. 

3) Fixed error in Universal Sensor Module CAN parameter file that was causing the User Cal 
Table Value at 1.25v to not send properly. 

 
 
Build 3.1.3 5/28/2008 

 
1) Fixed issue in IQ3 display canparm file that was not allowing the user to set the decimal 

on bottom center display on page 3. 
2) Added support for AF1 wideband controller. 
3) Added support for Chase Cam control module. 

 
 
Build 3.2.0 6/28/2008 

1) Fixed issue that was causing LapT Difference channel to not display properly under 
certain circumstances. 

2) Fixed issues that was causing program to hang when opening a data file with reference 
lap selected. 

3) Added support for the following VNET devices: 
a) Haltech 
b) XFI CAN 



c) Bosch 3.20 
d) Big Stuff CAN 

 
4) Added configuration file for IQ3 display only dash (NonLogger). 
5) Fixed error in DFI_MOD.canparm file. 

Build 3.2.1 7/18/2008 
1) Updated support for Big Stuff 3 ECU. 
2) Added support for BSG ECU. 
3) Added an error message when attempting to write the start/finish position file to a write 

protected memory card. 
4) Added user programmable stop record value and delay time for IQ3 and G2X. This 

feature also requires a firmware update. 
 
 
Build 3.3.0 10/17/2008 

1) Added new video player 
2) Updated canparm file for CHASE CAM module 
3) When uploading data from memory card, detailed view is now shown so you an see the 

date and time the file was created. CURRENTLY, THIS FEATURE DOES NOT WORK 
ON VISTA. FUTURE VERSIONS WILL SUPPORT VISTA FOR THIS FEATURE. 

4) Added the ability to program when to display the number of acquired satellites in center 
display for the IQ3. REQUIRES IQ3 FIRMWARE VERSION 8 OR HIGHER. 

5) Added RPM/Speed Ratio calculator on IQ3 Gear Calculation tab. 
6) Segment Report page now has the ability to exclude segments from the Theoretical Fast 

Lap calculation. This feature requires you to install the new IQ3 or G2X Config file when 
prompted at the Racepak product selection page. 

7) Segment Report page now has an Up and Down arrow to allow the viewing of laps that 
go beyond the bottom of the page. This feature requires you to install the new IQ3 or 
G2X Config file when prompted at the Racepak product selection page. 

8) Added support for ViPEC interface module. 
9) Windows98 installations now requires Media Player 9 or higher installed. 
10) DataLink installer is now combined to support both IQ3/G2X and V-Series installations. 

There is no longer a different CD for each type. The user must now make a product 
selection during the installation process. 

 
 
Build 3.4.0 Beta version only 

1) Added the ability for the user to import, synchronize and playback video files. Requires 
configuration file update. 

2) Improved Trackvision interface. Requires configuration file update. 
3) Added support for EFI Technology VNET interface module. 
4) Added various fuel level sender options to USM sensor drop down menu. 
5) Added the ability for the user to select the path to the weather station data file if the file 

cannot be found automatically. 
6) Added CG_NITROUS.canparm file. 
7) Added dash image files for PROII data logger. 
8) Added sensor type for Haltech module to allow user to change units to PSI and Deg F. 

 
 
Build 3.4.1 03/30/2009 Release version 

1) Added support for Sportsman data logger. 
 
Build 3.5.0 05/18/2009 

1) Added utility to calculate custom user calibration tables for USM. 
2) Added 10-180 ohm resistive pressure sender sensor types to USM. 
3) Fixed issue in G2X Pro and V300SD canparm files that could cause the data logger to 



revert back to factory default settings if using G2X Pro firmware version 53 or V300SD 
firmware version 18. 

4) Added the ability to program the GMT time and speed units in the IQ3 data logger via 
DataLink. Requires firmware version 12 or higher. 

5) Added the ability to program the IQ3 to flash the internal shift lights when the shift RPM 
value is exceeded. Requires IQ3 logger and display firmware version 12 or higher. 

6) Added the ability to program the lap number to display on the IQ3 logger dash. Requires 
firmware version 12 or higher. 

 
Build 3.5.1 09/04/2009 

1) Added Pro EFI interface module canparm file. 
2) Fixed error in Haltech canparm file that was setting the incorrect VNET ID when fuel 

pressure sensor type was selected. 
3) Fixed error in IQ3 Display canparm file that cause Shift Light Reset Level and Shift Light 

Reset Time to be swapped if Drag Race Mode was enabled. 
4) Fixed issue that could cause some channels buttons to not appear when creating a real- 

time telemetry file. 
5) Text in runlog page comments box now automatically wraps to the beginning of the next 

line when the text reaches the end. 
 
Build 3.6.0 11/09/2009 

1) Added Oil Temp and Exhaust Temp to the Haltech ECU sensor type drop down menu. 
2) Added support for NHRA user key. 
3) Added support for EC66 interface module. 
4) Added support for Hondata interface module. 
5) Added support for Pro EFI interface module. 
6) Added support for Omex interface module. 
7) Added support for Pro III data logger. 
8) Added support for Racepak single wire temperature sensor to USM. 
9) The data and config file format has changed in this version. Any new files that are 

created or previous files that are opened and saved in this version will not open in 
any previous DataLink version. It is highly recommend that you update all of your 
PC’s. 

 
Build 3.7.0 03/25/2010 

1) Added ability to record and display GPS date and time on Session runlog page. 
Requires configuration file update and the following firmware versions: 
 IQ3 – v14 
 G2X Red – v14 
 G2X Black – v45 
 G2X Pro – v56 

2) Fixed issue that could cause the scroll left and right buttons on the Segment Compare 
page to work incorrectly when the Ref Run Lap and the Selected Run Lap were from 
different data files. 

3) Fixed issue that was causing the GPS_Satellites channel to display incorrectly when real- 
time telemetry was running. 

4) Fixed issue that could cause the GPS data to shift incorrectly if a new recording was 
started before a GPS fix was acquired. 

5) Added support for Megasquirt I & II. 
6) Modified Pro III accelerometer canparm files. 
7) Added signed driver installation for Racepak USB devices. 
8) Double clicking on a .DDF raw data file will now launch a new instance of DataLink and 

start the new upload process. 
9) The USM channel calibration tool now calculates the end point slopes out to 0v and 5v. 
10) Added support for V300 HD Destroyer. 
11) The File->Open dialog box now defaults to the last successful File->Open folder instead 



of the RacepakData folder. 
 
Build 3.7.1 04/27/2010 

1) Fixed issue could corrupt GPS longitude when GPS speed was 0.00 
2) Fixed issue with Save As function that was introduced in v3.7.0 

 
Build 3.7.2 07/09/2010 

1) Fixed issue that was causing incorrect graph avg, min, max and avg time values when 
zooming. 

2) Fixed issue with incorrect math channel calculations when using attached channels. 
3) Fixed issue that was causing the graph area to not refresh after right clicking on a 

channel button and then clicking the Cancel button. 
4) Added support for MoTeC RS232 interface module. 

 
Build 3.7.3 10/18/2010 

1) Added support for Wolf V500 ECU. 
2) Added support for Hyperkontrol boost controller interface. 

 
Build 3.7.4 11/29/2010 

1) Added support for MSD 7730 ignition interface. 
2) Extended Haltech write delay time. 

 
Build 3.7.5 12/29/2010 

1) Added and updated canparm files for PRO III data logger. 
 
Build 3.8.0 01/28/2011 

1) Added canparm file to allow support for new M84 ECU. Requires firmware version 13 or 
higher to be installed in MoTeC VNET interface module. 

2) Added Step 5 CAN ID for MSD 7730 ignition interface. 
3) Changed some of the channel button naming strategies when new channels are added. 
4) Added Smartwire support. No online help yet but it will be added in the future. 
5) Added ability to select between vertical or horizontal scroll bar in channel button window 

pane. Selection can be made in Setting->Preferences. 
6) Added ability to change the channel button width. Selection can be made in 

Setting->Preferences. 
7) Modified Message Log dialog to hide communication details unless an error occurs. 
8) Fixed issue that could cause incorrect time offset in PROIII magneto current channels. 
9) Added the ability for the IQ3 to read the number connected VNET channels connected. 

Requires IQ3 firmware version 15 or higher. 
10) Added OBDII module support. 

 
 

Build 3.8.2 5/19/2011 
1) Added Smartwire canparm file option during installation. Only needed for use without a 

Racepak data logger. 
2) Added ability to update the Smartwire firmware via DataLink. 
3) Added canparm files for Traction Products transmission controller. 
4) When a configuration file is opened and selected, clicking File->Save As will result in the 

.rcg file extension to be selected instead of .rpk. 
 
Build 3.8.3 08/09/2011 

1) Highest COM port is no longer limited to COM9. 
2) Added support for AEM CAN interface. 
3) Added support for PROII magneto current logger. 
4) Added support for Smartwire set point delays. Also requires firmware v14. 



5) Fixed Smartwire graph smoothing control disabled on data file. 
6) Added terminator resistor on/off option to Switch Panel dialog box. 
7) Fixed GPS data offset issue introduced in DataLink v3.8.0. 
8) Fixed issue causing incorrect video sync time with Trackvision export. 

 
Build 3.8.4 10/25/2011 

1) Improved SmartWire interface. 
2) Added Help button to SmartWire dialogs. 
3) Added Read and Write shortcuts to toolbar. 

 
Build 3.8.5 12/12/2011 

1) Added support for SmartWire Switch Module. 
 
Build 3.8.6 

1) Added support for Torque Meter. 
2) Added support for RESET command parameter. 
3) Added support for AF4S. 

 
Build 4.0.3 08/07/2012 

1) Added ability to program the G2X Engine RPM source via DataLink. 
2) Fixed issue that could corrupt the SD card when selecting the "Force New Recording on 

Next Power Up" button on V300SD and Sportsman configuration files. 
3) Display a dialog box to allow telemetry setup after adding new channels. 
4) Added ability to start a new data telemetry session with just two mouse button clicks. 
5) Display confirmation when saving files. 
6) Added default configuration button to toolbar. 
7) Added support for GoPro Hero interface module. 
8) Added support for Texense 8 channel IR temperature sensor module. 

 
Build 4.1.1 09/28/2012 

1) Fixed issue that could cause the COM port to hang. 
2) Enabled SmartWire Print Report button. 
3) Added compatibility for transducer box firmware version 10 and higher to allow RPM 

channels. 
 
Build 4.2.0 01/15/2013 

1) Improved video playback performance and added slow playback feature. 
2) Added support for PROIIIA. 
3) Added support for V500SD. 
4) Added ability to select the data logger file when exporting data to Track Vision. 

 
Build 4.2.1 05/14/2013 

1) Added support for Link/Vipec EFI CAN interface module. 
2) Added 'Yes to All' and 'No to All' option when performing a Read VNET Config. 
3) Added support for PROIII warning and shift light modules. 
4) Fixed issue that would not allow the user to change the VNET ID on Smartwire switch 
5) input channels. 
6) Fixed issue that could cause DataLink to display incorrect configuration values after 
7) clicking the 'READ Configuration' button. 
8) Added Bluetooth support for PROIII and PROIIIA. 

 
Build 4.3.0 09/17/2013 

1) Added the ability to skip missing VNET channels when performing a Write VNET Config. 
2) Added the ability to enable/disable the power on bulb check on the 4 channel warning 

module. 



3) Added the ability to enable/disable the warning tag on the bottom of the IQ3 display. 
4) Fixed issue that could cause Datalink to crash when uploading a .ddf file with Smartwire 

channels. 
 
Build 4.3.1 10/17/2013 

1) Added support for FuelTech interface module. 
 
Build 4.3.2 11/26/2013 

1) Updated support for Link G4/Vipec EFI CAN interface module. 
2) Added support for Atomic LS EFI interface module. 
3) Added support for MicroTech ECU. 
4) Added support for USM_V2. 

 
Build 4.3.3 02/25/2014 

1) Added support for MSD 8771. 
2) Updated scalings in Hondata canparm file. 

 
Build 4.3.4 04/02/2014 

1) Added support for Atomic TBI interface module. 
 
Build 4.4.0 05/13/2014 

1) Fixed issue that was causing some transducer boxes to disappear when using the 'Show 
Topology' button. 

2) Added the ability to disable the configuration file assistant dialog. 
3) Fixed problem that would not allow the user to change the Vnet ID on the Smartwire 

switch box. 
4) Added the ability to dim the IQ3 backlight from a Vnet channel input value. Requires IQ3 

firmware version 26 or higher. 
 
Build 4.4.1 07/15/2014 

1) Modified TD_STRAIN_MOD and TD_STRAIN_MOD_P3 canparm files. 
 
Build 4.4.2 08/12/2014 

1) Added two new Vnet ID’s: Converter Pressure 0x399, and Traction Control 0x39A 
in CanID.canset file 

2) Fixed errors (duplicated sensor numbers) in TD_5V_MOD.canparm and 
TD_5V_MOD_P3.canparm files 

 
Build 4.5.0 01/6/2015 

1) Added support for IO_SHIFTLIGHT_V2 module. 
2) Added support for Megasquirt_CAN interface module. 
3) Added support for GPS module. 
4) Added support for PROIII data loggers to record and display the product information of 

the MSD 8771 when connected to the VNET bus. 
5) Added Vnet ID’s and scaling for Turbo Wastegate Position module. 

 
Build 4.5.1 04/30/2015 

1) Added support for IQ3 UTV RZR. 
 
Build 4.6.0 12/03/2015 

1) Added support for IQ3S Street dash. 
2) Added support for IQ3D Drag dash. 
3) Added support for Universal ECU Interface module. 
4) Added nitrous bottle pressure sensor types to EFI Technology Interface module. 



Build 4.6.1 02/04/2016 
1) Added support for the Haltech version of the IQ3 Street dash. 
2) Changed IQ3S Drag dash configuration filename from IQ3_Config_Race.cfg to 

IQ3_Config_Drag.cfg 
3) Added support for 500Hz shock travel module to the IQ3S and IQ3D dashes. 
4) Added support for Biotelemetry module. 
5) Added support for 2-Axis G-Meter module. 
6) Added ability to shift math channel lookup table points. 

 
 
Build 4.6.2 02/16/2016 

1) Fixed Telemetry conflict when adding an IQ3 Street dash to a data logger configuration. 
Requires firmware version 2.10 or higher. 

2) Added VNet ID’s for Traction Control and MSD Battery Voltage. 
3) Sets Logger Sample Rate to zero when disabling Fuel Tech channels. 

 
Build 4.6.3 03/15/2016 

1) Added Safety Box and Aux Analog VNet ID’s. 
2) Added support for eight keypad switch module. 

 
Build 4.7.0 07/01/2016 

1) Added support for dash app module. 
2) Added support for heart rate module. 
3) Added support for FuelTech FTCAN 2.0 protocol on Universal EFI interface module. 
4) Added support for Life Racing F88 protocol on Universal EFI interface module. 
5) Added "Read VNET Config (new channels)” to the Edit menu.  This will read and add 

new channels only so you can quickly add new channels without having to read the entire 
system. 

6) Fixed crashing issue when right clicking on channel button for TD box shift light modules 
with version 20 firmware. 

7) Added a description containing the current channel and the number channels to 
read/write while performing a Read and Write VNET Config. 

 
Build 4.7.1 07/13/2016 

1) Added support for Maxx ECU. 
2) Fixed problem with reading 2-Axis G-Meter module. 

 
Build 4.7.2 07/22/2016 

1) Added EFI Setup channel button to Universal CAN module when programmed to Pro 
EFI. 

2) Added ability to program the eight keypad backlight and LED brightness. 
3) Fixed potential issue when reading multiple modules with the same channel name. 

 
Build 4.7.3 09/07/2016 

1) Added support for EMS EM-Tech ECU. 
2) Made changes to Pro EFI sensor selection configuration. 
3) Changed IQ3S Haltech oil/ect warning channel to parking brake indicator. 

 
Build 4.7.4 09/16/2016 

1) Added support for Emtron ECU. 
2) Fixed a few errors in EMS EM-Tech canparm file. 
3) Updated image displayed in About dialog. 
4) Fixed issue with IQ3S Haltech that made the Gear Calculation tab disappear when the 

Warnings tab was selected. 



Build 4.7.5 10/26/2016 
1) Made changes to IQ3S Haltech warnings. 

 
Build 4.7.6 11/08/2016 

1) Added canparm file to allow user to change the MEFI4 ECU ID. May require data logger 
firmware update. 

2) Added warning message when uploading data and the number of recording VNET 
channels supported by the data logger was exceeded. May require data logger firmware 
update. 

 
Build 4.7.7 11/23/2016 

1) Made changes to Haltech canparm files. 
 
Build 4.8.0 01/09/2017 

1) Added graphing and Unilog importing of Electrimotion Command Module timer settings. 
Requires adding Runlog page to config file. 

2) Display the detected CAN bus type in IQ3S OBDII Setup dialog. 
3) Added the ability to update the IQ3S Haltech Logger firmware over USB. 
4) Added scaling for Q4X ride height sensor. 
5) Corrected Battery Voltage scaling in ECU_AEM.canparm. 

 
Build 4.8.1 03/16/2017 

1) Added support for IQ3 Street Logger dash. 
2) Added AFR scaling for E85 fuel. 

 
Build 4.8.2 04/17/2017 

1) Fixed bug introduced in version 4.8.1 that would not allow you to save the file after 
uploading data with a serial cable. 

2) Fixed Average time showing ‘ms’ instead of ‘us’ when displaying average time in 
microseconds. 

 
Build 4.8.3 07/27/2017 

1) Added Polaris RZR support to the Universal ECU Interface module. 
 
Build 4.8.4 08/23/2017 

1) Added dialog box for IO_SHIFTLITE_V2 that enables gear detection using gear ratio. 
2) Fixed issue introduced in version 4.8.1 that would cause an error when pressing the “On 

Condition” button in a PROIII Warning Light channel dialog. 
 
Build 4.8.5 09/07/2017 

1) Fixed issue that was causing an error message when reading a Universal ECU module 
with firmware 12 or lower installed. 

 
Build 4.8.6 12/01/2017 

1) Fixed the MEFI ECU Engine RPM and Coolant Temp scaling’s when using the Sensor 
drop down menu. 

2) Fixed mislabel on E2 Rad Water Out. 
3) Added support for new Pro Dash. 
4) Added support for Curtis controller. 

 
Build 4.8.7 01/15/2018 

1) Added support for A-Fuel Electrimotion Command Module. 



Build 4.8.8 01/25/2018 
1) Updates for Pro Dash. 

 
Build 4.8.9 02/07/2018 

1) Fixed typo in math channel operation atan2(x,y) to correctly read atan2(y,x). 
2) When exporting to ASCII file, the default path\filename is now the same as the selected 

data file with the filename extension changed from .rpk to .csv. 
3) Added support for DJE interface on 230-VM-EFIUCAN module. Requires firmware 

version 15 or higher. 
 
Build 4.8.10 05/02/2018 

1) Increased the number of set points that can be evaluated from 32 to 150 in the Pro Dash 
warning and Pro warning module. Requires Pro dash firmware 3 and Pro warning 
module firmware version 5. 

2) Fixed issue that could cause the program to crash after right clicking on a pro shift light 
channel button. 

 
Build 4.8.11 07/27/2018 

1) Added support for Holley Dominator V4 Standard protocol. 
2) Added support for Holley Sniper protocol. 
3) Added PROIII power switch lock feature. Requires firmware version 41. 

 
Build 4.8.12 11/14/2018 

1) Added VNet ID’s for Engines 3, 4 and 5. 
2) Added VNet ID for Transmission Lock Pressure. 
3) Added support for IQ3 Cobra Jet. 

 
Build 4.9.0 05/16/2019 

1) When reading VNET config, if channel is detected that is already in the config file but is 
reporting a different channel type it will automatically be removed and then added back in 
using the newly reported channel type. 

 
Build 5.0.0 01/24/2020 

1) Elimination of Licensing Disk requirement for Generic V300SD and Generic V500SD 
loggers 

2) Modified the DataLink installer to reflect the addition of the Generic V300SD and Generic 
V500SD loggers 

3) Modified DataLink to transparently convert LITE security levels to the standard security 
level(12) 

4) Fixed errors with channel parameters for type ECU_HOLLEY to be named correctly: 
EFI Boost Time was erroneously named EFI Boost Target 
EFI Line Temp was erroneously named EFI Line Press. 

 
Build 5.0.3 05/03/2021 

1) Fixed a bug with disappearing selected list box in IQ3Street configuration when the 
'All==>' button is clicked. 

2) Added new and modified some canparam files. 


